Emails are delayed in our US environment
Incident Report for Perception Point
Resolved
The incident in AWS is now resolved. Our system was operational in the last three hours and emails are scanned successfully
Posted Dec 08, 2021 - 00:46 UTC
Update
Email traffic is now recovered. We are still monitoring the system and we will wait with resolving the case once Amazon is resolving the case on their side.
It is now safe to turn the routing back to Perception Point. Please contact our support if you need any assistance with turning the rules back on
Posted Dec 07, 2021 - 23:29 UTC
Update
The AWS services are not yet fully recovered recovering but we are able to process more email traffic. Our customers should expect to receive delayed emails shortly.
We will update when it is safe to redirect emails again
Posted Dec 07, 2021 - 22:37 UTC
Monitoring
We are monitoring the traffic. We will notify when AWS recovers and when it's safe to turn the rules back on
Posted Dec 07, 2021 - 22:08 UTC
Update
While working with Amazon on recovering from the issue we recommend our customers switch off the routing rule if they are on M365 or Google Workspace
Posted Dec 07, 2021 - 18:20 UTC
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 17:36 UTC
Update
We are continuing to investigate the issue while AWS service in the US has degraded service
Posted Dec 07, 2021 - 17:36 UTC
Update
Amazon AWS experiences issues in the US region that are affecting our environment. The network issue was identified and they are working towards recovery
Posted Dec 07, 2021 - 16:48 UTC
Investigating
We are currently investigating an issue of delayed emails
Posted Dec 07, 2021 - 16:29 UTC
This incident affected: Email Scanning.