We are investigating reports about email delivery delays

Incident Report for Perception Point

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 16:39 UTC

Monitoring

We deployed a fix and the system is now functioning as expected. We are working to recover from the issue and monitoring the fix
Posted Jun 25, 2025 - 15:50 UTC

Identified

We have identified the issue and are now working to resolve it. Access to X-Ray is now restored for most customers and the email delay is shorter
Posted Jun 25, 2025 - 15:38 UTC

Investigating

We are currently investigating reports about email delivery delays
Posted Jun 25, 2025 - 14:56 UTC
This incident affected: XRAY (User Interface Only) and Email Scanning.