We are investigating an issue that may cause higher processing time and delayed emails in the EU environment.

Incident Report for Perception Point

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 10:53 UTC

Investigating

We are investigating an issue that may cause higher processing time and delayed emails in the EU environment.
Posted Sep 21, 2023 - 10:41 UTC
This incident affected: XRAY (User Interface Only).