We are experiencing a load that causes slight email delivery delays - Issue
Incident Report for Perception Point
Resolved
The issue is resolved and we are monitoring the system
Posted May 02, 2023 - 15:00 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 02, 2023 - 14:44 UTC
Identified
The team recognized the load, and is being handled now. The issue will be resolved in the next few minutes
Posted May 02, 2023 - 14:04 UTC
This incident affected: Email Scanning.