Delayed email delivery
Incident Report for Perception Point
Resolved
The issue is now resolved and email delivery is back to standard
Posted Nov 02, 2022 - 16:06 UTC
Investigating
You may experience some delays on email delivery
Posted Nov 02, 2022 - 14:48 UTC
This incident affected: Email Scanning.