Delays on delivery
Incident Report for Perception Point
Resolved
This incident has been resolved.
Posted Apr 03, 2023 - 11:50 UTC
Update
Under investigation
Posted Apr 03, 2023 - 11:28 UTC
Investigating
We are experiencing some delays with email delivery on EU region
Posted Apr 03, 2023 - 11:27 UTC
This incident affected: AWS (AWS ses-eu-west-1).